Skip to Main Content

Flipster

Instructions for using Flipster ejournals (magazines)

Flipster mobile features

The Flipster App is available to download from:

Requirements of the mobile app

Mobile device requirements for the Flipster App:

  • iOS 9 and higher for iPad and iPhone
  • Android Phones and Tablets running version 4.2.2 and Higher
  • Kindle Fire OS up to version 5.4.0.0

Further help and advice can be found via the Flipster App Help Guide below:

    Flipster Help Guide